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Abstract	
This experiment is designed to introduce a state-of-the-art hybrid silicon pixel x-rays detec8on system 
developed at CERN as a spin-off from the Large Hadron Collider (LHC). A basic understanding of semiconductor 
pixel detectors will be given by calibra8ng the detector with known x-ray sources and measuring the spectrum 
from radioac8ve sources. A variety of soGware tools will be used for data acquisi8on, detector calibra8on and 
data analysis. 

Objectives	
• Understand x-ray detec8on mechanisms in silicon pixel detectors; 

• Measure x-ray energy spectra from various x-ray sources; 

• Gain prac8cal skills in data acquisi8on using the specialised program Pixelman; 

• Prac8ce data mining skills. 

 

Caution	
This experiment involves the use of an x-ray source. Improper use could result in long-term health 
consequences. The source should be handled with care. The Timepix detec8on system is fragile and very 
expensive. Please handle with care. 

V. Franco Lima  Last updated: Saturday 6 July 2024 
 Page 1

?



	 Particle	detection	using	a	silicon	pixel	detector							  

 2024	
General	recommendations	
Use the folder “C:\Users\Lape\Desktop\YourName\” to store any files. There are ques8ons in the script 
highlighted with a            “?”  sign. These are ques8ons to guide the discussion. 
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TimePix	detectors	
The hybrid pixel detector is one of several types of instrumenta8on currently available for x-ray precision 
measurements. What other types of detectors do you know? It comprises a detec8on medium and readout 
electronics manufactured in different fabrica8on processes. Both parts of the detec8on system have a 
matching matrix of electrodes that are brought into contact via a process called bump bonding (see Figure 1). 
What other solid-state detectors apart from silicon are in use? 

The Timepix detector used in this experiment was developed by CERN and the Timepix Collabora8on (see 
Figure 2). It contains 256x256 pixels of 55x55 µm2 each that can operate in spectroscopic mode (Time-over-
Threshold mode, known as ToT mode), where energy informa8on is obtained at the same 8me as the posi8on 
of the interac8ons. What other modes can this device run in? The data is read out by a plug & play USB 
interface using the Pixelman soGware. How does the ToT mode work? Discuss with the demonstrator. 

 

Figure 1. Hybrid pixel detector schemaKcs. 
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Figure 2. TimePix detector. 
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Experimental procedures 

Experimental	setup	
Figure 3 shows the diagram of the detec8on system used for this experiment. It consists of various x-ray 
sources, (Get the energy of the fluorescence light from the source datasheet), a TimePix detector with USB 
interface and a PC used for data acquisi8on. 

The USB interface has two connec8ons. The LEMO cable provides DC bias to the silicon detector (+100V) from 
the USB interface. The USB cable powers the device and handles data acquisi8on. 

 

Figure 3. CharacterisKc x-ray spectra acquisiKon setup. 

Setting	up	the	detector	
Run the Pixelman program from the Desktop. Two windows should pop up, Medipix Control and Preview. The 
first one is used to control the parameters of data acquisi8on and set up the sensor, while the laeer displays 
the data recorded. The soGware is user friendly and most of the op8ons are self-explanatory. 

Check that the bias on the detector is set correctly on the panel (Device Control → Op0ons → Device Se3ngs 
→ Interface Specific Info tab). Check, that bias voltage is about 90 V (usually 80-98 V). Otherwise consult your 
demonstrator. Why do you need to bias a silicon detector? 

Check that the ToT clocking frequency is set to either 48 or 40 MHz  (Device Control → Op0ons → Device 
Se3ngs → Interface Specific Info tab, set TimePix clock value to 48). 
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Threshold	equalisation	
The Timepix sensor operates in a “noise-free” mode. The chip removes the electronic noise in the silicon 
detector system by seing an appropriate threshold (called THL in Pixelman), below which the signal induced in 
the pixel is disregarded. The threshold needs to be adjusted for each pixel with a per pixel threshold 
adjustment bit. Why would one need to equalise thresholds in different pixels? 

Each pixel in the chip responds in a slightly different way to incident radia8on due to transistor fabrica8on 
mismatches and non-uniformi8es of the detector. In order to obtain a beeer and more uniform response, the 
narrowest possible distribu8on of pixel threshold levels across the chip has to be found. The procedure for 
threshold equalisa8on is described below. It is recommended to perform this once a day to ensure uniform 
response of the chip. What could happen on another day that affects the performance of the detector? 

Device Control → File → Set Mode → Medipix 

Device Control → File → Reset Pixel Cfg. → All Bits 

Device Control → Tools → Threshold Equaliza0on 

A window similar to the one in Figure 4 will be displayed. Make sure that the parameter values on the leG-hand 
side of the window are as indicated. 

Press Start. The plot on the right hand side should look similar to the one in Figure 4. If the distribu8ons do not 
have Gaussian-like shapes, it could be due to too much ambient light incident on the detector. Cover it with 
black tape.  

This procedure takes about 10 minutes. Discuss with each other and the demonstrator what is happening 
during this procedure. Look at the results window and try and understand what it is showing you. 
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Figure 4. Threshold EqualizaKon of the chip. 

Device Control → Tools → DAC Control Panel (see Figure 5) 

The THL (threshold) value is ambient-temperature-dependent, but should be around 350-380 ADC. What do 
ADC and DAC stand for? Set THL to about 20-25 units below the indicated value (see Figure 5), e.g. if the 
displayed value is 385 ADC, set ~360-365 ADC. Note that a lower THL value here implies a higher threshold 
value. 

Close the Threshold Equaliza8on window. 

In the Device Control window set  

Acquisi0on type Integral 

Acquisi0on count 10 

Acquisi0on 0me 1 s 

Press Start to acquire data. In the Device Specific Seings panel set Max Level 1. Some pixels will be shown in 
red, indica8ng an excessive (> 100) number of counts. These are to be excluded from further data acquisi8on.  

If there is an excessive number of red pixels set the THL DAC level 5 lower.  
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Figure 5. Device Specific SeXngs control panel.
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Right click on the image area and select Mask... from the menu, enter 1 and press OK. These pixels should now 
be displayed in blue. 

The setup is now ready for data acquisi8on. Can noisy pixels appear in the future? Why? 

Time	over	Threshold	(ToT)	x-ray	energy	spectra	

Data	acquisition		
A photon of specific energy generates a certain number of electron–hole pairs in the detector. What energy is 
required to generate an electron-hole pair in silicon for ionisa8on from high-energy photons/par8cles? These 
are collected by the pixels and converted into digital units. There is a rela8on between incident photon energy 
and corresponding ADC value for a given detector. 

In order to establish this rela8on, spectra of known x-ray sources must be recorded. In this experiment 
characteris8c photons from he different sources available.  What are the different characterisRcs for alpha/
beta/gamma  energy deposiRons?  
 
There is limited 8me for this laboratory and it is not expected that a full energy calibra8on be possible. Data 
will be collected over the session to build a more detailed graph. Your results of x-ray energy and ToT value 
should be added to the Calibra8on Graph spread sheet on the desktop. 

It is important to look at the images collected in the Pixelman Preview window and at the spectra produced in 
the analysis sec8on. 

Place the source on top of the detector. In the Pixelman soGware follow this procedure. 

 

Device Control → File → Set Mode → 
Time Over Threshold 

Set the Acquisi8on Control parameters as 
shown in Figure 6. 

Acq. type Frames 

Acq. count 1000 

Acq. 0me 0.05 

Binary matrix 

√ Single file 
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Figure 6. Device Control panel.
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√ File output 

The output file should correspond to each target element to be recorded, e.g. for a Ba target the path should 
be 

“C:\Users\Lape\Desktop\YourName\Ba.tpx” 

Press start. In the Preview window interac8ons of X-rays with the silicon sensor will be displayed and recorded. 
There are several op8ons in the window available for beeer output data representa8on. Play around and figure 
out what they do. 

Acquire data for at least three of the following targets: (Cu, Mo, Ag, Rb, Ba, Tb); and also for Sr-90. 

Why does the image on the Preview screen look so different for the Sr-90 source? 

Data	analysis		
Interac8on of x-ray photons in the sensor is recorded in the form of digital units (ADC). These are converted 
into the incident photon energy using a calibraRon curve. Moreover, since the generated electron-hole cloud 
has a finite size, some8mes interac8ons are recorded by several pixels simultaneously. The spread of charge 
between adjacent pixels has to be corrected in order to obtain the correct spectrum (this is called clustering).  

A ROOT script will be used to perform the analysis of the data from Pixelman. Execute root by opening a cmd 
terminal from the program menu, and typing root. Then load the cluster analysis code on the ROOT terminal: 

.L C:\Macros\clusterAna.cpp 

Execu8ng the code reads TimePix data with the following input variables: data file, number of events, debug: 

readTimePix(“../Desktop/YourName/Ba.tpx”, 1000, false)  

The code returns to screen the number of clusters found per frame.  

What is a cluster? Why does the size distribu8on change with the energy of the x-ray? 

Why is there a different number of clusters for each target? Does that correspond to what you expect? Is the 
efficiency the same for all energies? 

When the analysis is finished a canvas appears that contains three graphs, the ToT (energy) spectra obtained 
for single pixel clusters, the energy spectra obtained for mul8-pixel clusters and the cluster size distribu8on. 

Think about the shape of the different spectra. Make a note of the peak(s) from the spectra and record this 
against the x-ray energy to form a calibra8on graph (excel macro on the desktop).  
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Are there any peaks present in the mul8-pixel clusters that are absent from the single pixel clusters, if so why?  

Why does the spectrum from the Sr-90 look so different to those from the other sources? Discuss you results 
among each other and with the demonstrator. 

Additional	literature		
1. Llopart X, Ballabriga R, Campbell M, Tlustos L, Wong W. Timepix, a 65k programmable pixel readout 

chip for arrival 8me, energy and/or photon coun8ng measurements. NIMA. 2007, 581(1-2):485-494. 
DOI: 10.1016/j.nima.2007.08.079 

2. Jakubek J, Cejnarova A, Holy T, et al. Pixel detectors for imaging with heavy charged par8cles. NIMA 
2008, 591(1):155-158. DOI: 10.1016/j.nima.2008.03.091 

3. Jakubek J. Semiconductor pixel detectors and their applica8ons in life sciences. Journal of 
InstrumentaRon. 2009;4(03):P03013-P03013. DOI: 10.1088/1748-0221/4/03/P03013  

4. Jakubek J. Data processing and image reconstruc8on methods for pixel detectors, NIMA. 2007, 
576(1):223-234. DOI: 10.1016/j.nima.2007.01.157 

5. Glenn F. Knoll, Radia8on Detec8on and Measurement, 3rd edi8on, John Wiley and Sons, 1999, Chapter 
2 (III), Chapter 11. 

6. Frank H. Aix and William C. Roesch (1968), Radia8on Dosimetry, 2nd ed., Academic Press, 95.  

7. Max Born (1989), Atomic Physics, 8th ed., New York: Dover Publica8ons, 126-127. 

8. G. P. Harnwell and J. J. Livingood (1933), Experimental Atomic Physics, 1st ed., MaGraw-Hill Book 
company, 363-365. 

9. J. C. Willmoe (1975), Atomic Physics, John Wiley & Sons Ltd., 324-328. 

Other	relevant	sources	of	information	
1. Timepix chip h[p://www.cern.ch/MEDIPIX 

2. Pixelman soGware h[p://aladdin.utef.cvut.cz/ofat/others/Pixelman/Pixelman.html 

3. Periodic table elements fluorescence X-ray energies h[p://xdb.lbl.gov/ 

4. ROOT Data Analysis Framework h[ps://root.cern.ch 
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